import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<h\\d.*?(?=<h\\d)";
final String string = "\n"
+ " <!-- wp:heading -->\n"
+ "<h2>header 1</h2>\n"
+ "<!-- /wp:heading -->\n\n"
+ "<!-- wp:paragraph -->\n"
+ "<p>Text text 1</p>\n"
+ "<!-- /wp:paragraph -->\n\n"
+ "<!-- wp:heading -->\n"
+ "<h2>header 2</h2>\n"
+ "<!-- /wp:heading -->\n\n"
+ "<!-- wp:paragraph -->\n"
+ "<p>Text text 2</p>\n"
+ "<!-- /wp:paragraph -->\n\n"
+ " ";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}