$re = '/<h\d.*?(?=<h\d)/s';
$str = '
<!-- wp:heading -->
<h2>header 1</h2>
<!-- /wp:heading -->
<!-- wp:paragraph -->
<p>Text text 1</p>
<!-- /wp:paragraph -->
<!-- wp:heading -->
<h2>header 2</h2>
<!-- /wp:heading -->
<!-- wp:paragraph -->
<p>Text text 2</p>
<!-- /wp:paragraph -->
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);