use strict;
my $str = '
<!-- wp:heading -->
<h2>header 1</h2>
<!-- /wp:heading -->
<!-- wp:paragraph -->
<p>Text text 1</p>
<!-- /wp:paragraph -->
<!-- wp:heading -->
<h2>header 2</h2>
<!-- /wp:heading -->
<!-- wp:paragraph -->
<p>Text text 2</p>
<!-- /wp:paragraph -->
';
my $regex = qr/<h\d.*?(?=<h\d)/sp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}