import Foundation
let pattern = #"<h\d.*?(?=<h\d)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .dotMatchesLineSeparators)
let testString = #"""
<!-- wp:heading -->
<h2>header 1</h2>
<!-- /wp:heading -->
<!-- wp:paragraph -->
<p>Text text 1</p>
<!-- /wp:paragraph -->
<!-- wp:heading -->
<h2>header 2</h2>
<!-- /wp:heading -->
<!-- wp:paragraph -->
<p>Text text 2</p>
<!-- /wp:paragraph -->
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)