#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:^\[Link\]\n[^\n]*+\n)++"
Local $sString = "[Link]" & @CRLF & _
"2017_07_11_RM_4b.pdf" & @CRLF & _
"[Link]" & @CRLF & _
"2017_07_11_RM_4b.pdf" & @CRLF & _
"some text" & @CRLF & _
"[Link]" & @CRLF & _
"2017_07_11_RM_4b.pdf" & @CRLF & _
"[Link]" & @CRLF & _
"2017_07_11_RM_4b.pdf" & @CRLF & _
"more text"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")