re = /(?:^\[Link\]\n[^\n]*+\n)++/m
str = '[Link]
2017_07_11_RM_4b.pdf
[Link]
2017_07_11_RM_4b.pdf
some text
[Link]
2017_07_11_RM_4b.pdf
[Link]
2017_07_11_RM_4b.pdf
more text'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end