using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:^\[Link\]\n[^\n]*+\n)++";
string input = @"[Link]
2017_07_11_RM_4b.pdf
[Link]
2017_07_11_RM_4b.pdf
some text
[Link]
2017_07_11_RM_4b.pdf
[Link]
2017_07_11_RM_4b.pdf
more text";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}