import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:^\\[Link\\]\\n[^\\n]*+\\n)++";
final String string = "[Link]\n"
+ "2017_07_11_RM_4b.pdf\n"
+ "[Link]\n"
+ "2017_07_11_RM_4b.pdf\n"
+ "some text\n"
+ "[Link]\n"
+ "2017_07_11_RM_4b.pdf\n"
+ "[Link]\n"
+ "2017_07_11_RM_4b.pdf\n"
+ "more text";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}