// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?:^\[Link\]\n[^\n]*+\n)++").unwrap();
let string = "[Link]
2017_07_11_RM_4b.pdf
[Link]
2017_07_11_RM_4b.pdf
some text
[Link]
2017_07_11_RM_4b.pdf
[Link]
2017_07_11_RM_4b.pdf
more text";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}