package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\S+\s+\S+\s+\w+\.\w+\s+(switch\d\d)\s`)
var str = `2018-07-19 08:00:00 Local6.Notice switch01 `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}