$re = '/^\S+\s+\S+\s+\w+\.\w+\s+(switch\d\d)\s/m';
$str = '2018-07-19 08:00:00 Local6.Notice switch01 ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);