re = /^\S+\s+\S+\s+\w+\.\w+\s+(switch\d\d)\s/m
str = '2018-07-19 08:00:00 Local6.Notice switch01 '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end