import re
regex = re.compile(r"^\S+\s+\S+\s+\w+\.\w+\s+(switch\d\d)\s", flags=re.MULTILINE)
test_str = "2018-07-19 08:00:00 Local6.Notice switch01 "
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")