import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\"valueList\"\\:\\s\\[\\s+(\\\"([0-9\\.]+)\\\")([,\\s]*\\\"([0-9\\.]+)\\\")([,\\s]*\\\"([0-9\\.]+)\\\")";
final String string = "\"result\": [\n"
+ " {\n"
+ " \"objName\": \"AAAA\"\n"
+ " \"timeList\": [\n"
+ " \"1629166200446\",\n"
+ " \"1629166202448\",\n"
+ " \"1629166204449\"\n"
+ " ],\n"
+ " \"valueList\": [\n"
+ " \"1111.0\",\n"
+ " \"2222.0\",\n"
+ " \"3333.0\"\n"
+ " ]\n"
+ " },\n"
+ " {\n"
+ " \"objName\": \"BBBB\"\n"
+ " \"timeList\": [\n"
+ " \"1629166200446\",\n"
+ " \"1629166202448\",\n"
+ " \"1629166204449\"\n"
+ " ],\n"
+ " \"valueList\": [\n"
+ " \"4444.0\",\n"
+ " \"5555.0\",\n"
+ " \"6666.0\"\n"
+ " ]\n"
+ " }\n"
+ " }\n"
+ "}";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}