$re = '/"valueList"\:\s\[\s+(\"([0-9\.]+)\")([,\s]*\"([0-9\.]+)\")([,\s]*\"([0-9\.]+)\")/m';
$str = '"result": [
{
"objName": "AAAA"
"timeList": [
"1629166200446",
"1629166202448",
"1629166204449"
],
"valueList": [
"1111.0",
"2222.0",
"3333.0"
]
},
{
"objName": "BBBB"
"timeList": [
"1629166200446",
"1629166202448",
"1629166204449"
],
"valueList": [
"4444.0",
"5555.0",
"6666.0"
]
}
}
}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);