use strict;
my $str = '"result": [
{
"objName": "AAAA"
"timeList": [
"1629166200446",
"1629166202448",
"1629166204449"
],
"valueList": [
"1111.0",
"2222.0",
"3333.0"
]
},
{
"objName": "BBBB"
"timeList": [
"1629166200446",
"1629166202448",
"1629166204449"
],
"valueList": [
"4444.0",
"5555.0",
"6666.0"
]
}
}
}';
my $regex = qr/"valueList"\:\s\[\s+(\"([0-9\.]+)\")([,\s]*\"([0-9\.]+)\")([,\s]*\"([0-9\.]+)\")/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}