const regex = /"valueList"\:\s\[\s+(\"([0-9\.]+)\")([,\s]*\"([0-9\.]+)\")([,\s]*\"([0-9\.]+)\")/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('"valueList"\\:\\s\\[\\s+(\\"([0-9\\.]+)\\")([,\\s]*\\"([0-9\\.]+)\\")([,\\s]*\\"([0-9\\.]+)\\")', 'gm')
const str = `"result": [
{
"objName": "AAAA"
"timeList": [
"1629166200446",
"1629166202448",
"1629166204449"
],
"valueList": [
"1111.0",
"2222.0",
"3333.0"
]
},
{
"objName": "BBBB"
"timeList": [
"1629166200446",
"1629166202448",
"1629166204449"
],
"valueList": [
"4444.0",
"5555.0",
"6666.0"
]
}
}
}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}