// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)"valueList"\:\s\[\s+(\"([0-9\.]+)\")([,\s]*\"([0-9\.]+)\")([,\s]*\"([0-9\.]+)\")"#).unwrap();
let string = "\"result\": [
{
\"objName\": \"AAAA\"
\"timeList\": [
\"1629166200446\",
\"1629166202448\",
\"1629166204449\"
],
\"valueList\": [
\"1111.0\",
\"2222.0\",
\"3333.0\"
]
},
{
\"objName\": \"BBBB\"
\"timeList\": [
\"1629166200446\",
\"1629166202448\",
\"1629166204449\"
],
\"valueList\": [
\"4444.0\",
\"5555.0\",
\"6666.0\"
]
}
}
}";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}