#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "/pt-br/aeroportos/(?!brasil)|/pt-br/localidades/(?!brasil)|/pt-br/locadora/[^/]+/((?!brasil).)+$"
Local $sString = "/pt-br/aeroportos/estados-unidos/mco-orlando-florida" & @CRLF & _
"/pt-br/" & @CRLF & _
"/pt-br/alugar/estados-unidos/miami-florida" & @CRLF & _
"/pt-br/aeroportos/estados-unidos/fll-fort-lauderdale-hollywood-fort-lauderdale-florida" & @CRLF & _
"/pt-br/localidades/estados-unidos/miami-florida" & @CRLF & _
"/pt-br/carros/estados-unidos/miami-florida" & @CRLF & _
"/pt-br/localidades/brasil/rio-de-janeiro-rio-de-janeiro" & @CRLF & _
"/pt-br/localidades/brasil/sao-paulo-sao-paulo" & @CRLF & _
"/pt-br/aeroportos/brasil/fln-hercilio-luz-florianopolis-santa-catarina" & @CRLF & _
"/pt-br/locadora/localiza/brasil/campinas-sao-paulo" & @CRLF & _
"/pt-br/locadora/localiza" & @CRLF & _
"/pt-br/locadora/localiza/brasil" & @CRLF & _
"/pt-br/locadora/localiza/estaasdasd/bananas"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")