import Foundation
let pattern = #"/pt-br/aeroportos/(?!brasil)|/pt-br/localidades/(?!brasil)|/pt-br/locadora/[^/]+/((?!brasil).)+$"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
/pt-br/aeroportos/estados-unidos/mco-orlando-florida
/pt-br/
/pt-br/alugar/estados-unidos/miami-florida
/pt-br/aeroportos/estados-unidos/fll-fort-lauderdale-hollywood-fort-lauderdale-florida
/pt-br/localidades/estados-unidos/miami-florida
/pt-br/carros/estados-unidos/miami-florida
/pt-br/localidades/brasil/rio-de-janeiro-rio-de-janeiro
/pt-br/localidades/brasil/sao-paulo-sao-paulo
/pt-br/aeroportos/brasil/fln-hercilio-luz-florianopolis-santa-catarina
/pt-br/locadora/localiza/brasil/campinas-sao-paulo
/pt-br/locadora/localiza
/pt-br/locadora/localiza/brasil
/pt-br/locadora/localiza/estaasdasd/bananas
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)