use strict;
my $str = '/pt-br/aeroportos/estados-unidos/mco-orlando-florida
/pt-br/
/pt-br/alugar/estados-unidos/miami-florida
/pt-br/aeroportos/estados-unidos/fll-fort-lauderdale-hollywood-fort-lauderdale-florida
/pt-br/localidades/estados-unidos/miami-florida
/pt-br/carros/estados-unidos/miami-florida
/pt-br/localidades/brasil/rio-de-janeiro-rio-de-janeiro
/pt-br/localidades/brasil/sao-paulo-sao-paulo
/pt-br/aeroportos/brasil/fln-hercilio-luz-florianopolis-santa-catarina
/pt-br/locadora/localiza/brasil/campinas-sao-paulo
/pt-br/locadora/localiza
/pt-br/locadora/localiza/brasil
/pt-br/locadora/localiza/estaasdasd/bananas';
my $regex = qr@/pt-br/aeroportos/(?!brasil)|/pt-br/localidades/(?!brasil)|/pt-br/locadora/[^/]+/((?!brasil).)+$@p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}