$re = '@/pt-br/aeroportos/(?!brasil)|/pt-br/localidades/(?!brasil)|/pt-br/locadora/[^/]+/((?!brasil).)+$@';
$str = '/pt-br/aeroportos/estados-unidos/mco-orlando-florida
/pt-br/
/pt-br/alugar/estados-unidos/miami-florida
/pt-br/aeroportos/estados-unidos/fll-fort-lauderdale-hollywood-fort-lauderdale-florida
/pt-br/localidades/estados-unidos/miami-florida
/pt-br/carros/estados-unidos/miami-florida
/pt-br/localidades/brasil/rio-de-janeiro-rio-de-janeiro
/pt-br/localidades/brasil/sao-paulo-sao-paulo
/pt-br/aeroportos/brasil/fln-hercilio-luz-florianopolis-santa-catarina
/pt-br/locadora/localiza/brasil/campinas-sao-paulo
/pt-br/locadora/localiza
/pt-br/locadora/localiza/brasil
/pt-br/locadora/localiza/estaasdasd/bananas';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);