# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/[^\n\d,.]+|[.,](?=.*[,.])//gm;t' <<< "123abs,5677
123,455
1,sf4
a,.d1d,f3ffv
1.33DF#$%#$#%34,5543dsf.er5rg%$%#"