# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"[^\n\d,.]+|[.,](?=.*[,.])"
test_str = ("123abs,5677\n"
"123,455\n"
"1,sf4\n"
"a,.d1d,f3ffv\n"
"1.33DF#$%#$#%34,5543dsf.er5rg%$%#")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.