#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)[^\n\d,.]+|[.,](?=.*[,.])"
Local $sString = "123abs,5677" & @CRLF & _
"123,455" & @CRLF & _
"1,sf4" & @CRLF & _
"a,.d1d,f3ffv" & @CRLF & _
"1.33DF#$%#$#%34,5543dsf.er5rg%$%#"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)