re = /[^\n\d,.]+|[.,](?=.*[,.])/m
str = '123abs,5677
123,455
1,sf4
a,.d1d,f3ffv
1.33DF#$%#$#%34,5543dsf.er5rg%$%#'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result