use strict;
my $str = '123abs,5677
123,455
1,sf4
a,.d1d,f3ffv
1.33DF#$%#$#%34,5543dsf.er5rg%$%#';
my $regex = qr/[^\n\d,.]+|[.,](?=.*[,.])/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";