#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^(?:[A-Za-z-]+\d|[\d-]+[A-Za-z])[\w-]*\s*"
Local $sString = "2fvRE-Ku89lkRVJ44QQFN ABACUS LABS, INC" & @CRLF & _
"abc123 CAT LABS, INC"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)