const regex = new RegExp('^(?:[A-Za-z-]+\\d|[\\d-]+[A-Za-z])[\\w-]*\\s*', 'gm')
const str = `2fvRE-Ku89lkRVJ44QQFN ABACUS LABS, INC
abc123 CAT LABS, INC`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);