// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?:[A-Za-z-]+\d|[\d-]+[A-Za-z])[\w-]*\s*").unwrap();
let string = "2fvRE-Ku89lkRVJ44QQFN ABACUS LABS, INC
abc123 CAT LABS, INC";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}