# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?:[A-Za-z-]+\d|[\d-]+[A-Za-z])[\w-]*\s*"
test_str = ("2fvRE-Ku89lkRVJ44QQFN ABACUS LABS, INC\n"
"abc123 CAT LABS, INC")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.