# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/{\s*+([^:{}]+:[^:{}]+?)\s*}/{ $1 }/gm;t' <<< ".foo {
color: red;
}
.bar {
color: blue;
font-size: 14px;
}
.baz { color: pink }
@media only screen and (max-width: 600px) {
body {
background-color: lightblue;
}
}
div {
color:
blue;
}"