use strict;
my $str = '.foo {
color: red;
}
.bar {
color: blue;
font-size: 14px;
}
.baz { color: pink }
@media only screen and (max-width: 600px) {
body {
background-color: lightblue;
}
}
div {
color:
blue;
}';
my $regex = qr/{\s*+([^:{}]+:[^:{}]+?)\s*}/mp;
my $subst = '{ $1 }';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";