import Foundation
let pattern = #"{\s*+([^:{}]+:[^:{}]+?)\s*}"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
.foo {
color: red;
}
.bar {
color: blue;
font-size: 14px;
}
.baz { color: pink }
@media only screen and (max-width: 600px) {
body {
background-color: lightblue;
}
}
div {
color:
blue;
}
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"{ $1 }"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)