package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m){\s*+([^:{}]+:[^:{}]+?)\s*}`)
var str = `.foo {
color: red;
}
.bar {
color: blue;
font-size: 14px;
}
.baz { color: pink }
@media only screen and (max-width: 600px) {
body {
background-color: lightblue;
}
}
div {
color:
blue;
}`
var substitution = "{ $1 }"
fmt.Println(re.ReplaceAllString(str, substitution))
}