$re = '/{\s*+([^:{}]+:[^:{}]+?)\s*}/m';
$str = '.foo {
color: red;
}
.bar {
color: blue;
font-size: 14px;
}
.baz { color: pink }
@media only screen and (max-width: 600px) {
body {
background-color: lightblue;
}
}
div {
color:
blue;
}';
$subst = "{ $1 }";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;