#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)<\/thead>((\s.*?)+)<\/table>"
Local $sString = "<div class="row">" & @CRLF & _
" <div class="col-sm-12 ui-resizable" data-type="container-content"><div data-type="component-text">" & @CRLF & _
" <h4>$company_name</h4>" & @CRLF & _
" </div>" & @CRLF & _
" <div data-type="component-text">" & @CRLF & _
" <table class="table table-bordered table-md">" & @CRLF & _
" <thead>" & @CRLF & _
" <tr>" & @CRLF & _
" <th>Item Name</th>" & @CRLF & _
" <th>Quantity</th>" & @CRLF & _
" <th>Rate</th>" & @CRLF & _
" <th>Gross</th>" & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
" <th>Discount</th>" & @CRLF & _
" <th>GST</th>" & @CRLF & _
" </tr>" & @CRLF & _
" </thead>" & @CRLF & _
" <tbody id="table-body">" & @CRLF & _
" <tr>" & @CRLF & _
" <td class="tab-data">$table_item_name</td>" & @CRLF & _
" <td class="tab-data">$table_quantity</td>" & @CRLF & _
" <td class="tab-data">$table_rate</td>" & @CRLF & _
" <td class="tab-data">$table_gross</td>" & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
" <td class="tab-data">$row_108</td>" & @CRLF & _
" <td class="tab-data">$row_109</td>" & @CRLF & _
" </tr>" & @CRLF & _
" </tbody>" & @CRLF & _
" </table>" & @CRLF & _
" </div>" & @CRLF & _
" </div>" & @CRLF & _
" </div>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")