# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<\/thead>((\s.*?)+)<\/table>"
test_str = ("<div class=\"row\">\n"
" <div class=\"col-sm-12 ui-resizable\" data-type=\"container-content\"><div data-type=\"component-text\">\n"
" <h4>$company_name</h4>\n"
" </div>\n"
" <div data-type=\"component-text\">\n"
" <table class=\"table table-bordered table-md\">\n"
" <thead>\n"
" <tr>\n"
" <th>Item Name</th>\n"
" <th>Quantity</th>\n"
" <th>Rate</th>\n"
" <th>Gross</th>\n"
" \n"
" \n"
" \n"
" <th>Discount</th>\n"
" <th>GST</th>\n"
" </tr>\n"
" </thead>\n"
" <tbody id=\"table-body\">\n"
" <tr>\n"
" <td class=\"tab-data\">$table_item_name</td>\n"
" <td class=\"tab-data\">$table_quantity</td>\n"
" <td class=\"tab-data\">$table_rate</td>\n"
" <td class=\"tab-data\">$table_gross</td>\n"
" \n"
" \n"
" \n"
" <td class=\"tab-data\">$row_108</td>\n"
" <td class=\"tab-data\">$row_109</td>\n"
" </tr>\n"
" </tbody>\n"
" </table>\n"
" </div>\n"
" </div>\n"
" </div>")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.