// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)<\/thead>((\s.*?)+)<\/table>").unwrap();
let string = "<div class=\"row\">
<div class=\"col-sm-12 ui-resizable\" data-type=\"container-content\"><div data-type=\"component-text\">
<h4>$company_name</h4>
</div>
<div data-type=\"component-text\">
<table class=\"table table-bordered table-md\">
<thead>
<tr>
<th>Item Name</th>
<th>Quantity</th>
<th>Rate</th>
<th>Gross</th>
<th>Discount</th>
<th>GST</th>
</tr>
</thead>
<tbody id=\"table-body\">
<tr>
<td class=\"tab-data\">$table_item_name</td>
<td class=\"tab-data\">$table_quantity</td>
<td class=\"tab-data\">$table_rate</td>
<td class=\"tab-data\">$table_gross</td>
<td class=\"tab-data\">$row_108</td>
<td class=\"tab-data\">$row_109</td>
</tr>
</tbody>
</table>
</div>
</div>
</div>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}