$re = '/<\/thead>((\s.*?)+)<\/table>/m';
$str = '<div class="row">
<div class="col-sm-12 ui-resizable" data-type="container-content"><div data-type="component-text">
<h4>$company_name</h4>
</div>
<div data-type="component-text">
<table class="table table-bordered table-md">
<thead>
<tr>
<th>Item Name</th>
<th>Quantity</th>
<th>Rate</th>
<th>Gross</th>
<th>Discount</th>
<th>GST</th>
</tr>
</thead>
<tbody id="table-body">
<tr>
<td class="tab-data">$table_item_name</td>
<td class="tab-data">$table_quantity</td>
<td class="tab-data">$table_rate</td>
<td class="tab-data">$table_gross</td>
<td class="tab-data">$row_108</td>
<td class="tab-data">$row_109</td>
</tr>
</tbody>
</table>
</div>
</div>
</div>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);