import Foundation
let pattern = #"<\/thead>((\s.*?)+)<\/table>"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
<div class="row">
<div class="col-sm-12 ui-resizable" data-type="container-content"><div data-type="component-text">
<h4>$company_name</h4>
</div>
<div data-type="component-text">
<table class="table table-bordered table-md">
<thead>
<tr>
<th>Item Name</th>
<th>Quantity</th>
<th>Rate</th>
<th>Gross</th>
<th>Discount</th>
<th>GST</th>
</tr>
</thead>
<tbody id="table-body">
<tr>
<td class="tab-data">$table_item_name</td>
<td class="tab-data">$table_quantity</td>
<td class="tab-data">$table_rate</td>
<td class="tab-data">$table_gross</td>
<td class="tab-data">$row_108</td>
<td class="tab-data">$row_109</td>
</tr>
</tbody>
</table>
</div>
</div>
</div>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)