using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(\w+)(?:\s+\1)+\b";
string substitution = @"\1";
string input = @"my example example example string contains example some text";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}