use strict;
my $str = 'my example example example string contains example some text';
my $regex = qr/\b(\w+)(?:\s+\1)+\b/p;
my $subst = '\\1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";