import re
regex = re.compile(r"\b(\w+)(?:\s+\1)+\b")
test_str = "my example example example string contains example some text"
subst = "\\1"
result = regex.sub(subst, test_str)
if result:
print(result)