$re = '/\b(\w+)(?:\s+\1)+\b/';
$str = 'my example example example string contains example some text';
$subst = "\1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;