const regex = /\b(\w+)(?:\s+\1)+\b/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(\\w+)(?:\\s+\\1)+\\b', 'g')
const str = `my example example example string contains example some text`;
const subst = `\1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);