const regex = /^((介绍|说说|讲讲)(一下|介绍)?)?(#是(什么|啥)(东西|玩意|哪(里|儿)|意思)?|(什么|啥)是#)(啊|呀|呢|阿)?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^((介绍|说说|讲讲)(一下|介绍)?)?(#是(什么|啥)(东西|玩意|哪(里|儿)|意思)?|(什么|啥)是#)(啊|呀|呢|阿)?$', 'gm')
const str = `介绍一下#
给我说说#
给我介绍一下#吧
说说#是什么
介绍一下#是啥
什么是#
#是啥啊
|#的?(简介|介绍)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}