import re
regex = re.compile(r"^((介绍|说说|讲讲)(一下|介绍)?)?(#是(什么|啥)(东西|玩意|哪(里|儿)|意思)?|(什么|啥)是#)(啊|呀|呢|阿)?$", flags=re.MULTILINE)
test_str = ("介绍一下#\n"
"给我说说#\n"
"给我介绍一下#吧\n\n"
"说说#是什么\n"
"介绍一下#是啥\n"
"什么是#\n"
"#是啥啊\n\n"
"|#的?(简介|介绍)")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")