import Foundation
let pattern = ##"^((介绍|说说|讲讲)(一下|介绍)?)?(#是(什么|啥)(东西|玩意|哪(里|儿)|意思)?|(什么|啥)是#)(啊|呀|呢|阿)?$"##
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
介绍一下#
给我说说#
给我介绍一下#吧
说说#是什么
介绍一下#是啥
什么是#
#是啥啊
|#的?(简介|介绍)
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)