#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<!Test1\s)Test2(?!\sTest3)"
Local $sString = "1. Test1 Test2 Test3" & @CRLF & _
"" & @CRLF & _
"2. Test1 Test2 NotTest3" & @CRLF & _
"" & @CRLF & _
"3. Test1Not Test2 Test3" & @CRLF & _
"" & @CRLF & _
"4. Test2" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")